Risolvere facilmente il problema delle ombre rosa in compiz (schede Nvidia e Hardy)

Come sicuramente molti utenti di ubuntu Hardy possessori di schede NVIDIA avranno notato, in hardy le finestre di compiz decidono arbitrariamente il colore della loro ombra.
Il più delle volte il colore è rosa, ma capita che questo cambi in varie tonalità (c’è chi le vede gialle, chi verdi). Se questo slancio glamour non richiesto (e a dire il vero non voluto… si tratta infatti di un bug della versione per hardy dei driver NVIDIA) vi disturba potete facilmente riportare tutto alla normalità con un semplice comando da terminale. Ecco come fare:

Aprite un terminale e digitate:

sudo ln -sf /usr/lib/nvidia/libwfb.so.xserver-xorg-core /usr/lib/xorg/modules/libwfb.so

inserite dunque la vostra password, sloggatevi, riloggatevi e… magia! Problema risolto :)

Post (forse) correlati:

    Nessun post correlato

Condividi questo articolo:

  • Digg
  • del.icio.us
  • Facebook
  • Twitter
  • Ping.fm
  • FriendFeed
  • LinkedIn
  • Wikio
  • MySpace
  • Google Bookmarks
  • Technorati
  • Live
  • MSN Reporter
  • Netvibes
  • PDF
  • email
maggio 9th, 2008 @ 02:01 PM • Classificato in GUIDE • Tags: , , commenti [9]

9 commenti

UrturinoNo Gravatar said,

Commento • maggio 10, 2008 @ 10:53 am

Ma io mi chiedo, se il problema si risolve cosi facilmente perché non ci hanno pensato loro prima delle release.
Bastava poco, no.

Rispondi

NeffNo Gravatar said,

Commento • maggio 10, 2008 @ 12:46 pm

Pare che misteriosamente si siano accorti dell’errore solamente in un secondo momento. Il problema non affligge tutte le schede nvidia…

Rispondi

hanzoNo Gravatar said,

Commento • maggio 11, 2008 @ 5:52 pm

sisi… ho seguito la questione su lauchpad fin dalla alpha e c’è una discussione lunga 3 pagine su questa cosa… non mi dicano che se ne sono accorti solo dopo, perché è una palla.
Sapevano che era un problema loro (e non dei driver) ed effettivamente se questa è la soluzione mi chiedo veramente come sia possibile che questo bug sia finito nella final release, soprattutto visto che è pure una LTS.
COmunque grazie mille di nuovo della soluzione, io avevo risolto installando i driver dal sito nvidia, ma ogni volta che aggiorno i kernel modules devo reinstallare…

Rispondi

Felpato90No Gravatar said,

Commento • maggio 12, 2008 @ 10:38 am

io ho 1 problema con la mia 8600 gs nn riesco a caricare i driver per far partire gli effetti grafici..please help

Rispondi

GarretNo Gravatar said,

Commento • maggio 18, 2008 @ 3:11 pm

Io credo di aver spasciato xorg così: ho dato il comando e ora al riavvio mi dice che ubuntu non riesce più a riconoscere scheda video e monitor. Ho una 8800GTS da 640MB, c’è un modo per annullare quel comando?

Rispondi

NeffNo Gravatar said,

Commento • maggio 19, 2008 @ 12:32 am

@Felpato90

Se usi ubuntu Hardy è semplice:

Sistema > Amministrazione > Driver Hardware

quindi metti un bel visto su “abilitato”. Riavvia il computer e sei a posto

@Garret

Mi sembra strano che sia il mio comando ad averti “spasciato” xorg dato che quello che fa è semplicemente creare un link simbolico… comunque puoi rimuovere il link se pensi sia questo il problema. Io non ho avuto nessunissimo problema

per rimuovere basta navigare fino alla cartella /usr/lib/xorg/modules/ ed eliminare il file libwfb.so che per l’appunto è il nostro link simbolico.
Comunque il problema delle ombre rosa dipende dal driver nvidia installato da ubuntu hardy. Se con questo sistema non riesci a risolvere il problema prova ad installare driver ufficiali nvidia. Il modo più semplice per farlo? Usa il pacchetto Envy di alberto milone. Lo puoi scaricare QUI.

Rispondi

UccioNo Gravatar said,

Commento • maggio 21, 2008 @ 12:50 am

Vorrei segnalare che con Hardy a 64 bit non ho avuto questo problema mentre ce l’ho avuto con Hardy a 32 bit.
Potrei sbagliarmi, ma mi pare che Hardy32 non ce le avesse neppure le ombre! In tal caso era normale che il problema non si fosse presentato (o anzi, ancora più grave :) )

Rispondi

UccioNo Gravatar said,

Commento • maggio 21, 2008 @ 1:06 am

Ops! Che pasticcio! Forse sarà l’ora… :)
Volevo dire:
… mi pare che Hardy64 non ce le avesse neppure le ombre!…

Rispondi

NeffNo Gravatar said,

Commento • maggio 21, 2008 @ 10:54 am

Ma anche Hardy 64 ha compiz giusto? come mai non dovrebbero esserci le ombre allora? Secondo me a questo punto risulta abbastanza chiaro che hardy 64 ha problemi di driver… avete già provato ad installare i driver ufficiali del sito NVIDIA (o EnvyNG di alberto milone?)

Rispondi

RSS feed dei commenti a questo articolo. TrackBack URI

Lascia un commento

Tutti i contenuti di Neffscape sono pubblicati secondo la licenza di utilizzo Creative Commons Attribution non commercial share alike 3.0.
• Neffscape è un sito pensato, creato e mantenuto da Marco Boneff